Help


Return to content

Browser compatibility

Our Internet services are optimised for the following browsers:
Windows users
  • Internet Explorer 8 or newer
  • Firefox 17 or newer
Mac OS X users
  • Safari 5 or newer
  • Firefox 17 or newer
Linux users
  • Firefox 17 or newer

If you are using an older version or some other browser than the ones mentioned above, defaults and limitations might appear in some services. In most Windows and Linux browsers you may check the browser version in the Help function. In Mac browsers you may check the browser version in the Apple menu by choosing About.

If you have further questions about our service, our eBusiness Help Desk will be pleased to assist you.